5211 C# Programming Manual: D:/5211/C# Directory Reference

5211 C# Programming Manual
C# Directory Reference

Files

file | JY5211CITask.cs
file | JY5211COTask.cs
file | JY5211DITask.cs
file | JY5211DOTask.cs
Generated by doxygen 1.9.1


5211 C# Programming Manual: D:/5211/C#/JY5211CITask.cs File Reference

Classes | Namespaces | Enumerations
JY5211CITask.cs File Reference

Classes

class | JY5211.JY5211CITask
class | JY5211.CISignalExport
CI Signal Export Class More...

Namespaces

namespace JY5211

Enumerations

enum class | JY5211.CIMode { JY5211.Single = JY5211Import.JY5211_CI_Single , JY5211.Finite = JY5211Import.JY5211_CI_Finite , JY5211.Continuous = JY5211Import.JY5211_CI_Continuous }
enum class JY5211.CIType {
JY5211.EdgeCounting , JY5211.Frequency , JY5211.Period , JY5211.Pulse ,
JY5211.TwoEdgeSeparation , JY5211.QuadEncoder , JY5211.TwoPulseEncoder
}
enum class | JY5211.CISignalExportSource { JY5211.StartTrig , JY5211.SampleClock }
SourceSignal More...


5211 C# Programming Manual: JY5211.JY5211CITask Class Reference

  • JY5211
  • JY5211CITask
Public Member Functions | Properties | List of all members
JY5211.JY5211CITask Class Reference

More...

Public Member Functions

JY5211CITask (int slotNum, int channel)
JY5211CITask (string boardName, int channel)
void | Start ()
void | SendSoftwareTrigger ()
void | Stop ()
void | ReadSinglePoint (out uint count)
void | ReadData (ref uint[] bufCount, int samplesToAcquire, int timeout=10000)
void | ReadData (ref uint[] bufCount, int timeout=10000)
void | ReadSinglePoint (out double measurement, int timeout=10000)
void | ReadData (ref double[] bufMeasurement, int samplesToAcquire, int timeout=10000)
void | ReadData (ref double[] bufMeasurement, int timeout=10000)
void | ReadSinglePoint (out double measurement1, out double measurement2, int timeout=10000)
void | ReadData (ref double[] bufMeasurement1, ref double[] bufMeasurement2, int samplesToAcquire, int timeout=10000)
void | ReadData (ref double[] bufMeasurement1, ref double[] bufMeasurement2, int timeout=10000)
bool | WaitUntilDone (int timeout=-1)

Properties

bool | IsRuning [get]
CIType | Type [get, set]
UInt64 | AvailableSamples [get]
UInt64 | TransferedSamples [get]
CIMode | Mode [get, set]
int | SamplesToAcquire [get, set]
CITrigger | Trigger [get, set]
JY5211Device | Device [get]
Sync | Sync [get, set]
CISampleClock | SampleClock [get, set]
uint | ChannelID [get]
EdgeCounting | EdgeCounting [get, set]
FrequencyMeas | FrequencyMeas [get, set]
PeriodMeas | PeriodMeas [get, set]
PulseMeas | PulseMeas [get, set]
TwoEdgeSeparation | TwoEdgeSeparation [get, set]
QuadEncoder | QuadEncoder [get, set]
TwoPulseEncoder | TwoPulseEncoder [get, set]
CISignalExport | SignalExport [get, set]
Export CI Signal Configuration More...

Detailed Description

JY5211计数器输入任务

JY5211 Counter Input Task.

Constructor & Destructor Documentation

◆ JY5211CITask() [1/2]

JY5211.JY5211CITask.JY5211CITask | ( | int | slotNum,
 |  | int | channel
 | ) |  |

用卡槽号创建一个CITask

Create a CITask with a slot number

Parameters
slotNum | 板卡槽位号Slot Number
channel | 计数器通道（0-7)Counter Channel (0-7)

◆ JY5211CITask() [2/2]

JY5211.JY5211CITask.JY5211CITask | ( | string | boardName,
 |  | int | channel
 | ) |  |

用板卡名称创建一个CITask

Create a CITask with a board name.

Parameters
boardName | 板卡名称Board Name
channel | 计数器通道（0-7)Counter channel (0-7)

Member Function Documentation

◆ ReadData() [1/6]

void JY5211.JY5211CITask.ReadData | ( | ref double[] | bufMeasurement,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000
 | ) |  |

从缓冲区读取指定长度的频率或周期值。当 JY5211CITask.Mode 不为 CIMode.Single， 且 Type 为 CIType.Frequency 或 CIType.Period 时可用。

Read frequency value or period value from buffer. Available when JY5211CITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | 读取测量值的缓存区。当 Type 为 CIType.Frequency 时为频率值（Hz）；当 Type 为 CIType.Period 时为周期值（秒）。Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
samplesToAcquire | 要读取的数据的长度。The length of the data to be read.
timeout | 超时时间(ms)。在读取到有效数据或超时前持续等待，如果超时，会抛出超时异常。当值为-1时为永不超时。Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [2/6]

void JY5211.JY5211CITask.ReadData | ( | ref double[] | bufMeasurement,
 |  | int | timeout = 10000
 | ) |  |

从缓冲区读取频率或周期值。当 JY5211CITask.Mode 不为 CIMode.Single， 且 Type 为 CIType.Frequency 或 CIType.Period 时可用。

Read frequency value or period value from buffer. Available when JY5211CITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | 读取测量值的缓存区。当 Type 为 CIType.Frequency 时为频率值（Hz）；当 Type 为 CIType.Period 时为周期值（秒）。Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
timeout | 超时时间(ms)。在读取到有效数据或超时前持续等待，如果超时，会抛出超时异常。当值为-1时为永不超时。Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [3/6]

void JY5211.JY5211CITask.ReadData | ( | ref double[] | bufMeasurement1,
 |  | ref double[] | bufMeasurement2,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000
 | ) |  |

从缓冲区取指定长度的脉冲高低电平持续时间或双边沿间隔长度或（一次两个结果）。当 JY5211CITask.Mode 不为 CIMode.Single， Type 为 CIType.Pulse 或 CIType.TwoEdgeSeparation 时可用。

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.. Available when JY5211CITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | 读取数据的缓存区1。当 Type 为 CIType.Pulse 时为高电平持续时间（秒）；当 Type 为 CIType.TwoEdgeSeparation 时为第一个信号的上升沿与第二个信号的上升沿之间的间隔。Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | 读取数据的缓存区2。当 Type 为 CIType.Pulse 时为低电平持续时间（秒）；当 Type 为 CIType.TwoEdgeSeparation 时为第二个信号的前一个上升沿与第一个信号的上升沿之间的间隔。Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
samplesToAcquire | 要读取的数据的长度。The length of the data to be read.
timeout | 超时时间(ms)。在读取到有效数据或超时前持续等待，如果超时，会抛出超时异常。当值为-1时为永不超时。Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [4/6]

void JY5211.JY5211CITask.ReadData | ( | ref double[] | bufMeasurement1,
 |  | ref double[] | bufMeasurement2,
 |  | int | timeout = 10000
 | ) |  |

从缓冲区取脉冲高低电平持续时间或双边沿间隔长度或（一次两个结果）。当 JY5211CITask.Mode 不为 CIMode.Single， Type 为 CIType.Pulse 或 CIType.TwoEdgeSeparation 时可用。

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.. Available when JY5211CITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | 读取数据的缓存区1。当 Type 为 CIType.Pulse 时为高电平持续时间（秒）；当 Type 为 CIType.TwoEdgeSeparation 时为第一个信号的上升沿与第二个信号的上升沿之间的间隔。Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | 读取数据的缓存区2。当 Type 为 CIType.Pulse 时为低电平持续时间（秒）；当 Type 为 CIType.TwoEdgeSeparation 时为第二个信号的前一个上升沿与第一个信号的上升沿之间的间隔。Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
timeout | 超时时间(ms)。在读取到有效数据或超时前持续等待，如果超时，会抛出超时异常。当值为-1时为永不超时。Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [5/6]

void JY5211.JY5211CITask.ReadData | ( | ref uint[] | bufCount,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000
 | ) |  |

从缓冲区读取指定长度的计数值。当 JY5211CITask.Mode 不为 CIMode.Single ，且 Type 为 CIType.EdgeCounting 、CIType.QuadEncoder 和 CIType.TwoPulseEncoder 时可用。

Read counter values from buffer. Available when JY5211CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder.

Parameters
bufCount | 读取数据的缓存区。Buffer for reading data.
samplesToAcquire | 要读取的数据的长度。The length of the data to be read.
timeout | 超时时间(ms)。在读取到有效数据或超时前持续等待，如果超时，会抛出超时异常。当值为-1时为永不超时。Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [6/6]

void JY5211.JY5211CITask.ReadData | ( | ref uint[] | bufCount,
 |  | int | timeout = 10000
 | ) |  |

从缓冲区读取计数值。当 JY5211CITask.Mode 不为 CIMode.Single ，且 Type 为 CIType.EdgeCounting 、CIType.QuadEncoder 和 CIType.TwoPulseEncoder 时可用。

Read counter values from buffer. Available when JY5211CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder.

Parameters
bufCount | 读取数据的缓存区。Buffer for reading data.
timeout | 超时时间(ms)。在读取到有效数据或超时前持续等待，如果超时，会抛出超时异常。当值为-1时为永不超时。Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [1/3]

void JY5211.JY5211CITask.ReadSinglePoint | ( | out double | measurement,
 |  | int | timeout = 10000
 | ) |  |

从寄存器读取频率或周期值。当 Type 为 CIType.Frequency 或 CIType.Period 时可用。

Read a signle frequency value or period value from register. Valid when Type is CIType.Frequency or CIType.Period.

Parameters
measurement 测量值。当 Type 为 CIType.Frequency 时为频率值（Hz）；当 Type 为 CIType.Period 时为周期值（秒）。Measurement value. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period is seconds when Type is CIType.Period.
timeout

超时时间(ms)。在测量完成或超时前持续等待，如果超时，会抛出超时异常。当值为-1时为永不超时。

Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [2/3]

void JY5211.JY5211CITask.ReadSinglePoint | ( | out double | measurement1,
 |  | out double | measurement2,
 |  | int | timeout = 10000
 | ) |  |

从寄存器读取脉冲高低电平持续时间或双边沿间隔长度或（一次两个结果）。当 Type 为 CIType.Pulse 或 CIType.TwoEdgeSeparation 时可用。

Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register. Available when Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
measurement1 | 测量值1。当 Type 为 CIType.Pulse 时为高电平持续时间（秒）；当 Type 为 CIType.TwoEdgeSeparation 时为第一个信号的上升沿与第二个信号的上升沿之间的间隔。Measurement Value 1. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
measurement2 | 测量值2。当 Type 为 CIType.Pulse 时为低电平持续时间（秒）；当 Type 为 CIType.TwoEdgeSeparation 时为第二个信号的前一个上升沿与第一个信号的上升沿之间的间隔。Measurement Value 2. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
timeout

超时时间(ms)。在测量完成或超时前持续等待，如果超时，会抛出超时异常。当值为-1时为永不超时。

Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [3/3]

void JY5211.JY5211CITask.ReadSinglePoint ( out uint count )

从寄存器读取计数值。当 Type 为 CIType.EdgeCounting 、CIType.QuadEncoder 和 CIType.TwoPulseEncoder 时可用。

Read a signle count value from register. Available when Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder .

Parameters
count 计数值Count Value

◆ SendSoftwareTrigger()

void JY5211.JY5211CITask.SendSoftwareTrigger ( )

产生一个软件触发信号

Generate a software trigger signal

◆ Start()

void JY5211.JY5211CITask.Start ( )

启动CI任务

Start CI task

◆ Stop()

void JY5211.JY5211CITask.Stop ( )

停止CI任务

Stop CI task

◆ WaitUntilDone()

bool JY5211.JY5211CITask.WaitUntilDone ( int timeout = -1 )

等待当前任务完成。

Wait until current task is completed.

Parameters
timeout 超时时间(ms)。在当前任务完成前持续等待，如果超时，会抛出超时异常。当值为-1时为永不超时。Timeout (ms). Wait until current task to be completed. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

Property Documentation

◆ AvailableSamples

UInt64 JY5211.JY5211CITask.AvailableSamples
get

缓冲区内可以读取的每通道点数。当 Mode 不为 CIMode.Single 时有效。

Number of samples per channel that can be read from the buffer. Valid when Mode is NOT CIMode.Single.

◆ ChannelID

uint JY5211.JY5211CITask.ChannelID
get

本任务所的通道号

Channel ID

◆ Device

JY5211Device JY5211.JY5211CITask.Device
get

本任务所使用的设备

Device used by this task

◆ EdgeCounting

EdgeCounting JY5211.JY5211CITask.EdgeCounting
getset

边沿计数配置。当 Type 为 CIType.EdgeCounting 时有效。

Edge Counting Configuration. Valid when Type is CIType.EdgeCounting.

◆ FrequencyMeas

FrequencyMeas JY5211.JY5211CITask.FrequencyMeas
getset

频率测量配置。当 Type 为 CIType.Frequency 时有效。

Frequency Measurement Configuration. Valid when Type is CIType.Frequency.

◆ IsRuning

bool JY5211.JY5211CITask.IsRuning
get

任务是否正在运行

Whether the task is running

◆ Mode

CIMode JY5211.JY5211CITask.Mode
getset

采样模式

Sampling Mode

◆ PeriodMeas

PeriodMeas JY5211.JY5211CITask.PeriodMeas
getset

周期测量配置。当 Type 为 CIType.Period 时有效。

Period Measurement Configuration. Valid when Type is CIType.Period.

◆ PulseMeas

PulseMeas JY5211.JY5211CITask.PulseMeas
getset

脉冲测量配置。当 Type 为 CIType.Pulse 时有效。

Pulse Measurement Configuration. Valid when Type is CIType.Pulse.

◆ QuadEncoder

QuadEncoder JY5211.JY5211CITask.QuadEncoder
getset

正交编码器配置。当 Type 为 CIType.QuadEncoder 时有效。

Quad Encoder Configuration. Valid when Type is CIType.QuadEncoder.

◆ SampleClock

CISampleClock JY5211.JY5211CITask.SampleClock
getset

采样时钟配置

Sample Clock Configuration

◆ SamplesToAcquire

int JY5211.JY5211CITask.SamplesToAcquire
getset

每通道采集的样点数。当 Mode 为 CIMode.Finite 时有效。

Number of samples to be acquired per channel. Only valid when Mode is CIMode.Finite.

◆ SignalExport

CISignalExport JY5211.JY5211CITask.SignalExport
getset

Export CI Signal Configuration

◆ Sync

Sync JY5211.JY5211CITask.Sync
getset

同步设置

Sync Configuration

◆ TransferedSamples

UInt64 JY5211.JY5211CITask.TransferedSamples
get

已从缓冲区内读取的每通道点数。当 Mode 不为 CIMode.Single 时有效。

Number of points per channel that has already been read from the buffer. Valid when Mode is NOT CIMode.Single.

◆ Trigger

CITrigger JY5211.JY5211CITask.Trigger
getset

触发配置

Trigger Configuration

◆ TwoEdgeSeparation

TwoEdgeSeparation JY5211.JY5211CITask.TwoEdgeSeparation
getset

双边沿间隔测量配置。当 Type 为 CIType.TwoEdgeSeparation 时有效。

Two-Edge Separation Measurement Configuration. Valid when Type is CIType.TwoEdgeSeparation.

◆ TwoPulseEncoder

TwoPulseEncoder JY5211.JY5211CITask.TwoPulseEncoder
getset

双脉冲编码器配置。当 Type 为 CIType.TwoPulseEncoder 时有效。

Two-Pulse Encoder Configuration. Valid when Type is CIType.TwoPulseEncoder.

◆ Type

CIType JY5211.JY5211CITask.Type
getset

应用类型

Application Type

The documentation for this class was generated from the following file:
  • D:/5211/C#/JY5211CITask.cs


5211 C# Programming Manual: JY5211.CISignalExport Class Reference

  • CISignalExport
Public Member Functions | List of all members
JY5211.CISignalExport Class Reference

CI Signal Export Class More...

Public Member Functions

void | Add (CISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination More...
void | Add (CISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination More...
void | Clear (SignalExportDestination destination)
Clear one Signal Export More...
void | ClearAll ()
Clear All Signal Export More...

Detailed Description

CI Signal Export Class

Member Function Documentation

◆ Add() [1/2]

void JY5211.CISignalExport.Add | ( | CISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations
 | ) |  |

Export one Signal to Mutil Desination

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5211.CISignalExport.Add | ( | CISignalExportSource | source,
 |  | SignalExportDestination | destination
 | ) |  |

Export one Signal to Desination

Parameters
source | CI Signal Source
destination | Export Desination

◆ Clear()

void JY5211.CISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export

Parameters
destination Export Desination

◆ ClearAll()

void JY5211.CISignalExport.ClearAll ( )

Clear All Signal Export

The documentation for this class was generated from the following file:
  • D:/5211/C#/JY5211CITask.cs


5211 C# Programming Manual: D:/5211/C#/JY5211COTask.cs File Reference

Classes | Namespaces | Enumerations
JY5211COTask.cs File Reference

Classes

class | JY5211.JY5211COTask
class | JY5211.COTrigger
class | JY5211.CODigitalTrigger
class | JY5211.COExternalTimebase
class | JY5211.COTimebase
class | JY5211.COSignalExport
CI Signal Export Class More...

Namespaces

namespace JY5211

Enumerations

enum class | JY5211.COIdleState { JY5211.HighLevel = JY5211Import.JY5211_CO_HighLevel , JY5211.LowLevel = JY5211Import.JY5211_CO_LowLevel }
enum class | JY5211.COMode { JY5211.Single = JY5211Import.JY5211_CO_Single , JY5211.Finite = JY5211Import.JY5211_CO_Finite , JY5211.ContinuousWrapping = JY5211Import.JY5211_CO_ContinuousWrapping , JY5211.ContinuousNoWrapping = JY5211Import.JY5211_CO_ContinuousNoWrapping }
enum class | JY5211.COTriggerType { JY5211.Immediate = JY5211Import.JY5211_TriggerType_Immediately , JY5211.Digital = JY5211Import.JY5211_TriggerType_Digital , JY5211.Software = JY5211Import.JY5211_TriggerType_Soft }
enum class | JY5211.CODigitalTriggerEdge { JY5211.Rising }
enum class | JY5211.COTimebaseSource { JY5211.Internal200MHz = JY5211Import.JY5211_Internal_MainClk_200M , JY5211.Internal5MHz = JY5211Import.JY5211_Internal_Timebase_5M , JY5211.Internal100kHz = JY5211Import.JY5211_Internal_Timebase_100K , JY5211.External = JY5211Import.JY5211_External_Timebase }
enum class | JY5211.COSignalExportSource { JY5211.StartTrig }
SourceSignal More...


5211 C# Programming Manual: JY5211.JY5211COTask Class Reference

  • JY5211COTask
Public Member Functions | Properties | List of all members
JY5211.JY5211COTask Class Reference

More...

Public Member Functions

JY5211COTask (int slotNum, int channel)
JY5211COTask (string boardName, int channel)
void | WriteSinglePoint (COPulse pulse)
void | WriteData (COPulse[] pulsesGroup, int samplesToWrite, int timeout=10000)
void | SendSoftwareTrigger ()
void | Start ()
void | Stop ()
bool | WaitUntilDone (int timeout=-1)

Properties

bool | IsRuning [get]
IOTerminal | OutputTerminal [get, set]
COMode | Mode [get, set]
COTimebase | Timebase [get, set]
COTrigger | Trigger [get, set]
Sync | Sync [get, set]
COIdleState | IdleState [get, set]
double | InitialDelay [get, set]
uint | AvaliableLenInSamples [get]
ulong | TransferedSamples [get]
uint | TransferedPulses [get]
JY5211Device | Device [get]
COSignalExport | SignalExport [get, set]
Export CI Signal Configuration More...
uint | ChannelID [get]

Detailed Description

JY5211计数器输出任务

JY5211 Counter Output Task

Constructor & Destructor Documentation

◆ JY5211COTask() [1/2]

JY5211.JY5211COTask.JY5211COTask | ( | int | slotNum,
 |  | int | channel
 | ) |  |

用卡槽号创建一个COTask

Create a COTask with a slot number

Parameters
slotNum | 板卡槽位号Slot number
channel | 计数器通道（0-7)Counter channel (0-7)

◆ JY5211COTask() [2/2]

JY5211.JY5211COTask.JY5211COTask | ( | string | boardName,
 |  | int | channel
 | ) |  |

用板卡名称创建一个COTask

Create a COTask with a board name.

Parameters
boardName | 板卡名称Board Name
channel | 计数器通道（0-7）Counter channel (0-7)

Member Function Documentation

◆ SendSoftwareTrigger()

void JY5211.JY5211COTask.SendSoftwareTrigger ( )

产生一个软件触发信号。仅当 COTrigger.Type 为 COStartTriggerType.Software 时有效。

Generate a software trigger signal. Valid when COTrigger.Type is COStartTriggerType.Software.

◆ Start()

void JY5211.JY5211COTask.Start ( )

启动CO任务

Start CO task

◆ Stop()

void JY5211.JY5211COTask.Stop ( )

停止CO任务

Stop CO task

◆ WaitUntilDone()

bool JY5211.JY5211COTask.WaitUntilDone ( int timeout = -1 )

等待当前任务完成。

Wait until current task is completed.

Parameters
timeout 超时时间(ms)。在当前任务完成前持续等待，如果超时，会抛出超时异常。当值为-1时为永不超时。Timeout (ms). Wait until current task to be completed. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ WriteData()

void JY5211.JY5211COTask.WriteData | ( | COPulse[] | pulsesGroup,
 |  | int | samplesToWrite,
 |  | int | timeout = 10000
 | ) |  |

向缓冲区写入需要输出的脉冲参数。在 Mode 不为 COMode.Single 时可用。当 Mode 为 COMode.Finite 或 COMode.ContinuousWrapping 时，仅允许开始任务前调用一次。

Write pulse parameters to be output to the buffer. Valid when Mode is NOT COMode.Single. When Mode is COMode.Finite or COMode.ContinuousWrapping, this function can only be called once before starting the task.

Parameters
pulsesGroup | 一组脉冲参数A group of pulse parameters
samplesToWrite | 要写入的的Sample数量。如果 Mode 为 COMode.ContinuousNoWrapping, 开始任务前需要先至少写入2组数据。Number of samples to write. If Mode is COMode.ContinuousNoWrapping, you need to write at least 2 samples before starting the task.
timeout | 超时时间(ms)。在所有数据写入到缓冲区前或超时前持续等待，如果超时，会抛出超时异常。当值为-1时为永不超时。Timeout (ms). Wait until all data is written to buffer or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ WriteSinglePoint()

void JY5211.JY5211COTask.WriteSinglePoint ( COPulse pulse )

向寄存器单点写入需要输出的脉冲参数。在 Mode 为 COMode.Single 时有效。当正在发送的脉冲的数量为无穷时，该函数在开始任务后也可用。

Write a single pulse parameter to the register. Valid when Mode is COMode.Single. This function is also available after starting the task when the number of pulses being sent is infinite.

Parameters
pulse 脉冲参数Pulse Parameter

Property Documentation

◆ AvaliableLenInSamples

uint JY5211.JY5211COTask.AvaliableLenInSamples
get

板载缓冲区当前可写入的样点数（每通道）。当 Mode 不为 COMode.Single 时有效。

The number of samples that can be written into the onboard buffer (per channel). Valid when Mode is NOT COMode.Single.

◆ ChannelID

uint JY5211.JY5211COTask.ChannelID
get

本任务所的通道号

Channel ID

◆ Device

JY5211Device JY5211.JY5211COTask.Device
get

本任务所使用的设备

The device used by this task

◆ IdleState

COIdleState JY5211.JY5211COTask.IdleState
getset

空闲状态时的输出电平状态。默认值为 COIdleState.LowLevel。

Outut level in idle state. The default values is COIdleState.LowLevel.

◆ InitialDelay

double JY5211.JY5211COTask.InitialDelay
getset

输出脉冲的初始延迟时间（秒）。最小值为生效时基的3个周期（Tick）。

Counter output initial delay in seconds. There are five ticks of the timebase fixed delay in counter internal, so the total delay(s) = InitialDelay + (5 / timebase)

◆ IsRuning

bool JY5211.JY5211COTask.IsRuning
get

任务是否正在运行

Whether the task is running

◆ Mode

COMode JY5211.JY5211COTask.Mode
getset

计数器输出模式

Counter Output Mode

◆ OutputTerminal

IOTerminal JY5211.JY5211COTask.OutputTerminal
getset

脉冲输出端口

Pulse Output Terminal

◆ SignalExport

COSignalExport JY5211.JY5211COTask.SignalExport
getset

Export CI Signal Configuration

◆ Sync

Sync JY5211.JY5211COTask.Sync
getset

同步设置

Sync configuration

◆ Timebase

COTimebase JY5211.JY5211COTask.Timebase
getset

时基配置。仅适用于 Mode 为 COMode.Single时，其余模式下时基固定为内部200MHz时基。

Timebase configuration. Only valid when Mode is COMode.Single, in other modes the timebase is fixed at internal 200MHz timebase.

◆ TransferedPulses

uint JY5211.JY5211COTask.TransferedPulses
get

当前配置下已发送的脉冲的数量。

The number of pulses transfered under the current configuration.

◆ TransferedSamples

ulong JY5211.JY5211COTask.TransferedSamples
get

已从本地缓冲区传出的样点数（每通道），当 Mode 不为 COMode.Single 时有效。

The number of samples that have been transfered from the local buffer (per channel). Valid when Mode is NOT COMode.Single.

◆ Trigger

COTrigger JY5211.JY5211COTask.Trigger
getset

触发配置

Trigger Configuration

The documentation for this class was generated from the following file:
  • D:/5211/C#/JY5211COTask.cs


5211 C# Programming Manual: JY5211.COTrigger Class Reference

  • COTrigger
Properties | List of all members
JY5211.COTrigger Class Reference

More...

Properties

COTriggerType | Type [get, set]
CODigitalTrigger | Digital [get, set]

Detailed Description

CO触发参数配置类

CO trigger parameter configuration class

Property Documentation

◆ Digital

CODigitalTrigger JY5211.COTrigger.Digital
getset

数字触发设置

Digital Trigger Congfiguration

◆ Type

COTriggerType JY5211.COTrigger.Type
getset

触发类型。默认为 COTriggerType.Immediate。

Trigger type. The default value is COTriggerType.Immediate.

The documentation for this class was generated from the following file:
  • D:/5211/C#/JY5211COTask.cs


5211 C# Programming Manual: JY5211.CODigitalTrigger Class Reference

  • CODigitalTrigger
Properties | List of all members
JY5211.CODigitalTrigger Class Reference

More...

Properties

TriggerTerminal | Source [get, set]
CODigitalTriggerEdge | Edge [get, set]

Detailed Description

CO数字触发设置

Set CO Digital trigger

Property Documentation

◆ Edge

CODigitalTriggerEdge JY5211.CODigitalTrigger.Edge
getset

触发信号的有效沿

Digital Trigger Active Edge

◆ Source

TriggerTerminal JY5211.CODigitalTrigger.Source
getset

CO数字触发源。

CO Digital Trigger source.

The documentation for this class was generated from the following file:
  • D:/5211/C#/JY5211COTask.cs


5211 C# Programming Manual: JY5211.COExternalTimebase Class Reference

  • COExternalTimebase
Properties | List of all members
JY5211.COExternalTimebase Class Reference

More...

Properties

ClockTerminal | Terminal [get, set]
double | Frequency [get, set]

Detailed Description

外部时基配置类

External timebase configuration class

Property Documentation

◆ Frequency

double JY5211.COExternalTimebase.Frequency
getset

外部时基的频率

Frequency of The External Timebase

◆ Terminal

ClockTerminal JY5211.COExternalTimebase.Terminal
getset

外部时基的输入端口

External Timebase Input Terminal

The documentation for this class was generated from the following file:
  • D:/5211/C#/JY5211COTask.cs


5211 C# Programming Manual: JY5211.COTimebase Class Reference

  • COTimebase
Properties | List of all members
JY5211.COTimebase Class Reference

More...

Properties

COTimebaseSource | Source [get, set]
COExternalTimebase | External [get, set]

Detailed Description

时基配置类

Timebase configuration class

Property Documentation

◆ External

COExternalTimebase JY5211.COTimebase.External
getset

外部时基配置。当 COTimebase.Source 为 COTimebaseSource.External时有效。

External Timebase Configuration. Valid when COTimebase.Source is COTimebaseSource.External.

◆ Source

COTimebaseSource JY5211.COTimebase.Source
getset

时基源。默认值为 COTimebaseSource.Internal200MHz。

Timebase Source. The default value is COTimebaseSource.Internal200MHz.

The documentation for this class was generated from the following file:
  • D:/5211/C#/JY5211COTask.cs


5211 C# Programming Manual: JY5211.COSignalExport Class Reference

  • COSignalExport
Public Member Functions | List of all members
JY5211.COSignalExport Class Reference

CI Signal Export Class More...

Public Member Functions

void | Add (COSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination More...
void | Add (COSignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination More...
void | Clear (SignalExportDestination destination)
Clear one Signal Export More...
void | ClearAll ()
Clear All Signal Export More...

Detailed Description

CI Signal Export Class

Member Function Documentation

◆ Add() [1/2]

void JY5211.COSignalExport.Add | ( | COSignalExportSource | source,
 |  | List< SignalExportDestination > | destinations
 | ) |  |

Export one Signal to Mutil Desination

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5211.COSignalExport.Add | ( | COSignalExportSource | source,
 |  | SignalExportDestination | destination
 | ) |  |

Export one Signal to Desination

Parameters
source | CI Signal Source
destination | Export Desination

◆ Clear()

void JY5211.COSignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export

Parameters
destination Export Desination

◆ ClearAll()

void JY5211.COSignalExport.ClearAll ( )

Clear All Signal Export

The documentation for this class was generated from the following file:
  • D:/5211/C#/JY5211COTask.cs


5211 C# Programming Manual: D:/5211/C#/JY5211DITask.cs File Reference

Classes | Namespaces
JY5211DITask.cs File Reference

Classes

class JY5211.JY5211DITask

Namespaces

namespace JY5211


5211 C# Programming Manual: JY5211.JY5211DITask Class Reference

  • JY5211DITask
Public Member Functions | Properties | List of all members
JY5211.JY5211DITask Class Reference

More...

Public Member Functions

JY5211DITask (int slotNum)
JY5211DITask (string boardName)
void | AddLine (IOTerminal lineID)
void | AddLine (IOTerminal[] linesID)
void | RemoveLine (IOTerminal line)
void | RemoveLine (IOTerminal[] lines)
void | Start ()
void | Stop ()
void | ReadSinglePoint (ref bool[] buf)
void | ReadSinglePoint (IOTerminal line, out bool readValue)

Properties

bool | IsRuning [get]
JY5211Device | Device [get]
List< IOTerminal > | Lines [get]

Detailed Description

JY5211数字输入任务

JY5211 Digital Input Task.

Constructor & Destructor Documentation

◆ JY5211DITask() [1/2]

JY5211.JY5211DITask.JY5211DITask ( int slotNum )

用卡槽号创建一个DITask

Create a DITask with a slot number

Parameters
slotNum 板卡槽位号Slot Number

◆ JY5211DITask() [2/2]

JY5211.JY5211DITask.JY5211DITask ( string boardName )

用板卡名称创建一个DITask

Create a COTask with a board name.

Parameters
boardName 板卡名称Board Name

Member Function Documentation

◆ AddLine() [1/2]

void JY5211.JY5211DITask.AddLine ( IOTerminal lineID )

添加端口

Add Line

Parameters
lineID 端口Line

◆ AddLine() [2/2]

void JY5211.JY5211DITask.AddLine ( IOTerminal[] linesID )

添加多个端口

Add Multiple Lines

Parameters
linesID 所有要添加的端口的ID。IDs of all lines to be added.

◆ ReadSinglePoint() [1/2]

void JY5211.JY5211DITask.ReadSinglePoint | ( | IOTerminal | line,
 |  | out bool | readValue
 | ) |  |

从指定端口读取数据。

Read data from a specified line.

Parameters
line | 指定的管脚。Specified line.
readValue | 被指定的管脚的数据。Data of the specified line.

◆ ReadSinglePoint() [2/2]

void JY5211.JY5211DITask.ReadSinglePoint ( ref bool[] buf )

从所有已添加的端口读取数据。

Read data from all added lines.

Parameters
buf 用于获取数据的用户缓存。User buffer for reading data.

◆ RemoveLine() [1/2]

void JY5211.JY5211DITask.RemoveLine ( IOTerminal line )

移除端口

Remove Line

Parameters
line 端口Line

◆ RemoveLine() [2/2]

void JY5211.JY5211DITask.RemoveLine ( IOTerminal[] lines )

移除多个端口

Add Multiple Lines

Parameters
lines 所有要移除的端口的。Lines to be removed.

◆ Start()

void JY5211.JY5211DITask.Start ( )

启动DI任务

Start DI task

◆ Stop()

void JY5211.JY5211DITask.Stop ( )

停止DI任务

Stop DI task

Property Documentation

◆ Device

JY5211Device JY5211.JY5211DITask.Device
get

本任务所使用的设备

Device used by this task

◆ IsRuning

bool JY5211.JY5211DITask.IsRuning
get

任务是否正在运行

Whether the task is running

◆ Lines

List<IOTerminal> JY5211.JY5211DITask.Lines
get

已添加的端口

Added TerminalsS

The documentation for this class was generated from the following file:
  • D:/5211/C#/JY5211DITask.cs


5211 C# Programming Manual: D:/5211/C#/JY5211DOTask.cs File Reference

Classes | Namespaces
JY5211DOTask.cs File Reference

Classes

class JY5211.JY5211DOTask

Namespaces

namespace JY5211


5211 C# Programming Manual: JY5211.JY5211DOTask Class Reference

  • JY5211DOTask
Public Member Functions | Properties | List of all members
JY5211.JY5211DOTask Class Reference

More...

Public Member Functions

JY5211DOTask (int slotNum)
JY5211DOTask (string boardName)
void | AddLine (IOTerminal lineID)
void | AddLine (IOTerminal[] linesID)
void | RemoveLine (IOTerminal lineID)
void | RemoveLine (IOTerminal[] linesID)
void | Start ()
void | Stop ()
void | WriteSinglePoint (bool[] buf)

Properties

JY5211Device | Device [get]
bool | IsRuning [get]
List< IOTerminal > | Lines [get]

Detailed Description

JY5211数字输出任务

JY5211 Digital Output Task.

Constructor & Destructor Documentation

◆ JY5211DOTask() [1/2]

JY5211.JY5211DOTask.JY5211DOTask ( int slotNum )

用卡槽号创建一个DOTask

Create a DOTask with a slot number

Parameters
slotNum 板卡槽位号Slot Number

◆ JY5211DOTask() [2/2]

JY5211.JY5211DOTask.JY5211DOTask ( string boardName )

用板卡名称创建一个DOTask

Create a DOTask with a board name.

Parameters
boardName 板卡名称Board Name

Member Function Documentation

◆ AddLine() [1/2]

void JY5211.JY5211DOTask.AddLine ( IOTerminal lineID )

添加端口

Add Line

Parameters
lineID 端口ID。当该值为-1时，添加所有端口。Line ID。All lines would be added if this value equals -1.

◆ AddLine() [2/2]

void JY5211.JY5211DOTask.AddLine ( IOTerminal[] linesID )

添加多个端口

Add Multiple Lines

Parameters
linesID 所有要添加的端口的ID。IDs of all lines to be added.

◆ RemoveLine() [1/2]

void JY5211.JY5211DOTask.RemoveLine ( IOTerminal lineID )

移除端口

Remove Line

Parameters
lineID 端口ID。当该值为-1时，移除所有已添加的端口。Line ID。All added lines would be removed if this value equals -1.

◆ RemoveLine() [2/2]

void JY5211.JY5211DOTask.RemoveLine ( IOTerminal[] linesID )

移除多个端口

Add Multiple Lines

Parameters
linesID 所有要移除的端口的ID。IDs of all lines to be removed.

◆ Start()

void JY5211.JY5211DOTask.Start ( )

启动DO任务

Start DO task

◆ Stop()

void JY5211.JY5211DOTask.Stop ( )

停止DO任务

Stop DO task

◆ WriteSinglePoint()

void JY5211.JY5211DOTask.WriteSinglePoint ( bool[] buf )

写入数据到所有已添加的端口。

Write data to all added lines.

Parameters
buf 用于写入数据的用户缓存。User buffer for writting data.

Property Documentation

◆ Device

JY5211Device JY5211.JY5211DOTask.Device
get

本任务所使用的设备

Device used by this task

◆ IsRuning

bool JY5211.JY5211DOTask.IsRuning
get

任务是否正在运行

Whether the task is running

◆ Lines

List<IOTerminal> JY5211.JY5211DOTask.Lines
get

已添加的端口

Added TerminalsS

The documentation for this class was generated from the following file:
  • D:/5211/C#/JY5211DOTask.cs


5211 C# Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY5211 |
C JY5211CITask |
C CISignalExport | CI Signal Export Class
C JY5211COTask |
C COTrigger |
C CODigitalTrigger |
C COExternalTimebase |
C COTimebase |
C COSignalExport | CI Signal Export Class
C JY5211DITask |
C JY5211DOTask |


5211 C# Programming Manual: Member List

  • CISignalExport
JY5211.CISignalExport Member List

This is the complete list of members for JY5211.CISignalExport, including all inherited members.

Add(CISignalExportSource source, SignalExportDestination destination) | JY5211.CISignalExport
Add(CISignalExportSource source, List< SignalExportDestination > destinations) | JY5211.CISignalExport
Clear(SignalExportDestination destination) | JY5211.CISignalExport
ClearAll() | JY5211.CISignalExport


5211 C# Programming Manual: Member List

  • CODigitalTrigger
JY5211.CODigitalTrigger Member List

This is the complete list of members for JY5211.CODigitalTrigger, including all inherited members.

Edge | JY5211.CODigitalTrigger
Source | JY5211.CODigitalTrigger


5211 C# Programming Manual: Member List

  • COExternalTimebase
JY5211.COExternalTimebase Member List

This is the complete list of members for JY5211.COExternalTimebase, including all inherited members.

Frequency | JY5211.COExternalTimebase
Terminal | JY5211.COExternalTimebase


5211 C# Programming Manual: Member List

  • COSignalExport
JY5211.COSignalExport Member List

This is the complete list of members for JY5211.COSignalExport, including all inherited members.

Add(COSignalExportSource source, SignalExportDestination destination) | JY5211.COSignalExport
Add(COSignalExportSource source, List< SignalExportDestination > destinations) | JY5211.COSignalExport
Clear(SignalExportDestination destination) | JY5211.COSignalExport
ClearAll() | JY5211.COSignalExport


5211 C# Programming Manual: Member List

  • COTimebase
JY5211.COTimebase Member List

This is the complete list of members for JY5211.COTimebase, including all inherited members.

External | JY5211.COTimebase
Source | JY5211.COTimebase


5211 C# Programming Manual: Member List

  • COTrigger
JY5211.COTrigger Member List

This is the complete list of members for JY5211.COTrigger, including all inherited members.

Digital | JY5211.COTrigger
Type | JY5211.COTrigger


5211 C# Programming Manual: Member List

  • JY5211CITask
JY5211.JY5211CITask Member List

This is the complete list of members for JY5211.JY5211CITask, including all inherited members.

AvailableSamples | JY5211.JY5211CITask
ChannelID | JY5211.JY5211CITask
Device | JY5211.JY5211CITask
EdgeCounting | JY5211.JY5211CITask
FrequencyMeas | JY5211.JY5211CITask
IsRuning | JY5211.JY5211CITask
JY5211CITask(int slotNum, int channel) | JY5211.JY5211CITask
JY5211CITask(string boardName, int channel) | JY5211.JY5211CITask
Mode | JY5211.JY5211CITask
PeriodMeas | JY5211.JY5211CITask
PulseMeas | JY5211.JY5211CITask
QuadEncoder | JY5211.JY5211CITask
ReadData(ref uint[] bufCount, int samplesToAcquire, int timeout=10000) | JY5211.JY5211CITask
ReadData(ref uint[] bufCount, int timeout=10000) | JY5211.JY5211CITask
ReadData(ref double[] bufMeasurement, int samplesToAcquire, int timeout=10000) | JY5211.JY5211CITask
ReadData(ref double[] bufMeasurement, int timeout=10000) | JY5211.JY5211CITask
ReadData(ref double[] bufMeasurement1, ref double[] bufMeasurement2, int samplesToAcquire, int timeout=10000) | JY5211.JY5211CITask
ReadData(ref double[] bufMeasurement1, ref double[] bufMeasurement2, int timeout=10000) | JY5211.JY5211CITask
ReadSinglePoint(out uint count) | JY5211.JY5211CITask
ReadSinglePoint(out double measurement, int timeout=10000) | JY5211.JY5211CITask
ReadSinglePoint(out double measurement1, out double measurement2, int timeout=10000) | JY5211.JY5211CITask
SampleClock | JY5211.JY5211CITask
SamplesToAcquire | JY5211.JY5211CITask
SendSoftwareTrigger() | JY5211.JY5211CITask
SignalExport | JY5211.JY5211CITask
Start() | JY5211.JY5211CITask
Stop() | JY5211.JY5211CITask
Sync | JY5211.JY5211CITask
TransferedSamples | JY5211.JY5211CITask
Trigger | JY5211.JY5211CITask
TwoEdgeSeparation | JY5211.JY5211CITask
TwoPulseEncoder | JY5211.JY5211CITask
Type | JY5211.JY5211CITask
WaitUntilDone(int timeout=-1) | JY5211.JY5211CITask


5211 C# Programming Manual: Member List

  • JY5211COTask
JY5211.JY5211COTask Member List

This is the complete list of members for JY5211.JY5211COTask, including all inherited members.

AvaliableLenInSamples | JY5211.JY5211COTask
ChannelID | JY5211.JY5211COTask
Device | JY5211.JY5211COTask
IdleState | JY5211.JY5211COTask
InitialDelay | JY5211.JY5211COTask
IsRuning | JY5211.JY5211COTask
JY5211COTask(int slotNum, int channel) | JY5211.JY5211COTask
JY5211COTask(string boardName, int channel) | JY5211.JY5211COTask
Mode | JY5211.JY5211COTask
OutputTerminal | JY5211.JY5211COTask
SendSoftwareTrigger() | JY5211.JY5211COTask
SignalExport | JY5211.JY5211COTask
Start() | JY5211.JY5211COTask
Stop() | JY5211.JY5211COTask
Sync | JY5211.JY5211COTask
Timebase | JY5211.JY5211COTask
TransferedPulses | JY5211.JY5211COTask
TransferedSamples | JY5211.JY5211COTask
Trigger | JY5211.JY5211COTask
WaitUntilDone(int timeout=-1) | JY5211.JY5211COTask
WriteData(COPulse[] pulsesGroup, int samplesToWrite, int timeout=10000) | JY5211.JY5211COTask
WriteSinglePoint(COPulse pulse) | JY5211.JY5211COTask


5211 C# Programming Manual: Member List

  • JY5211DITask
JY5211.JY5211DITask Member List

This is the complete list of members for JY5211.JY5211DITask, including all inherited members.

AddLine(IOTerminal lineID) | JY5211.JY5211DITask
AddLine(IOTerminal[] linesID) | JY5211.JY5211DITask
Device | JY5211.JY5211DITask
IsRuning | JY5211.JY5211DITask
JY5211DITask(int slotNum) | JY5211.JY5211DITask
JY5211DITask(string boardName) | JY5211.JY5211DITask
Lines | JY5211.JY5211DITask
ReadSinglePoint(ref bool[] buf) | JY5211.JY5211DITask
ReadSinglePoint(IOTerminal line, out bool readValue) | JY5211.JY5211DITask
RemoveLine(IOTerminal line) | JY5211.JY5211DITask
RemoveLine(IOTerminal[] lines) | JY5211.JY5211DITask
Start() | JY5211.JY5211DITask
Stop() | JY5211.JY5211DITask


5211 C# Programming Manual: Member List

  • JY5211DOTask
JY5211.JY5211DOTask Member List

This is the complete list of members for JY5211.JY5211DOTask, including all inherited members.

AddLine(IOTerminal lineID) | JY5211.JY5211DOTask
AddLine(IOTerminal[] linesID) | JY5211.JY5211DOTask
Device | JY5211.JY5211DOTask
IsRuning | JY5211.JY5211DOTask
JY5211DOTask(int slotNum) | JY5211.JY5211DOTask
JY5211DOTask(string boardName) | JY5211.JY5211DOTask
Lines | JY5211.JY5211DOTask
RemoveLine(IOTerminal lineID) | JY5211.JY5211DOTask
RemoveLine(IOTerminal[] linesID) | JY5211.JY5211DOTask
Start() | JY5211.JY5211DOTask
Stop() | JY5211.JY5211DOTask
WriteSinglePoint(bool[] buf) | JY5211.JY5211DOTask


5211 C# Programming Manual: Class Index

Class Index
C | J
C
CISignalExport (JY5211)
CODigitalTrigger (JY5211)
COExternalTimebase (JY5211)
COSignalExport (JY5211)
COTimebase (JY5211)
COTrigger (JY5211)
J
JY5211CITask (JY5211)
JY5211COTask (JY5211)
JY5211DITask (JY5211)
JY5211DOTask (JY5211)


5211 C# Programming Manual: D: Directory Reference

  • D:
D: Directory Reference

Directories

directory 5211


5211 C# Programming Manual: D:/5211 Directory Reference

  • D:
  • 5211
5211 Directory Reference

Directories

directory C#


5211 C# Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 1234]
▼ D:
▼ 5211
▼ C#
JY5211CITask.cs
JY5211COTask.cs
JY5211DITask.cs
JY5211DOTask.cs


5211 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- a -

  • Add() : JY5211.CISignalExport , JY5211.COSignalExport
  • AddLine() : JY5211.JY5211DITask , JY5211.JY5211DOTask
  • AvailableSamples : JY5211.JY5211CITask
  • AvaliableLenInSamples : JY5211.JY5211COTask

- c -

  • ChannelID : JY5211.JY5211CITask , JY5211.JY5211COTask
  • Clear() : JY5211.CISignalExport , JY5211.COSignalExport
  • ClearAll() : JY5211.CISignalExport , JY5211.COSignalExport

- d -

  • Device : JY5211.JY5211CITask , JY5211.JY5211COTask , JY5211.JY5211DITask , JY5211.JY5211DOTask
  • Digital : JY5211.COTrigger

- e -

  • Edge : JY5211.CODigitalTrigger
  • EdgeCounting : JY5211.JY5211CITask
  • External : JY5211.COTimebase

- f -

  • Frequency : JY5211.COExternalTimebase
  • FrequencyMeas : JY5211.JY5211CITask

- i -

  • IdleState : JY5211.JY5211COTask
  • InitialDelay : JY5211.JY5211COTask
  • IsRuning : JY5211.JY5211CITask , JY5211.JY5211COTask , JY5211.JY5211DITask , JY5211.JY5211DOTask

- j -

  • JY5211CITask() : JY5211.JY5211CITask
  • JY5211COTask() : JY5211.JY5211COTask
  • JY5211DITask() : JY5211.JY5211DITask
  • JY5211DOTask() : JY5211.JY5211DOTask

- l -

  • Lines : JY5211.JY5211DITask , JY5211.JY5211DOTask

- m -

  • Mode : JY5211.JY5211CITask , JY5211.JY5211COTask

- o -

  • OutputTerminal : JY5211.JY5211COTask

- p -

  • PeriodMeas : JY5211.JY5211CITask
  • PulseMeas : JY5211.JY5211CITask

- q -

  • QuadEncoder : JY5211.JY5211CITask

- r -

  • ReadData() : JY5211.JY5211CITask
  • ReadSinglePoint() : JY5211.JY5211CITask , JY5211.JY5211DITask
  • RemoveLine() : JY5211.JY5211DITask , JY5211.JY5211DOTask

- s -

  • SampleClock : JY5211.JY5211CITask
  • SamplesToAcquire : JY5211.JY5211CITask
  • SendSoftwareTrigger() : JY5211.JY5211CITask , JY5211.JY5211COTask
  • SignalExport : JY5211.JY5211CITask , JY5211.JY5211COTask
  • Source : JY5211.CODigitalTrigger , JY5211.COTimebase
  • Start() : JY5211.JY5211CITask , JY5211.JY5211COTask , JY5211.JY5211DITask , JY5211.JY5211DOTask
  • Stop() : JY5211.JY5211CITask , JY5211.JY5211COTask , JY5211.JY5211DITask , JY5211.JY5211DOTask
  • Sync : JY5211.JY5211CITask , JY5211.JY5211COTask

- t -

  • Terminal : JY5211.COExternalTimebase
  • Timebase : JY5211.JY5211COTask
  • TransferedPulses : JY5211.JY5211COTask
  • TransferedSamples : JY5211.JY5211CITask , JY5211.JY5211COTask
  • Trigger : JY5211.JY5211CITask , JY5211.JY5211COTask
  • TwoEdgeSeparation : JY5211.JY5211CITask
  • TwoPulseEncoder : JY5211.JY5211CITask
  • Type : JY5211.COTrigger , JY5211.JY5211CITask

- w -

  • WaitUntilDone() : JY5211.JY5211CITask , JY5211.JY5211COTask
  • WriteData() : JY5211.JY5211COTask
  • WriteSinglePoint() : JY5211.JY5211COTask , JY5211.JY5211DOTask


5211 C# Programming Manual: Class Members - Functions

- a -

  • Add() : JY5211.CISignalExport , JY5211.COSignalExport
  • AddLine() : JY5211.JY5211DITask , JY5211.JY5211DOTask

- c -

  • Clear() : JY5211.CISignalExport , JY5211.COSignalExport
  • ClearAll() : JY5211.CISignalExport , JY5211.COSignalExport

- j -

  • JY5211CITask() : JY5211.JY5211CITask
  • JY5211COTask() : JY5211.JY5211COTask
  • JY5211DITask() : JY5211.JY5211DITask
  • JY5211DOTask() : JY5211.JY5211DOTask

- r -

  • ReadData() : JY5211.JY5211CITask
  • ReadSinglePoint() : JY5211.JY5211CITask , JY5211.JY5211DITask
  • RemoveLine() : JY5211.JY5211DITask , JY5211.JY5211DOTask

- s -

  • SendSoftwareTrigger() : JY5211.JY5211CITask , JY5211.JY5211COTask
  • Start() : JY5211.JY5211CITask , JY5211.JY5211COTask , JY5211.JY5211DITask , JY5211.JY5211DOTask
  • Stop() : JY5211.JY5211CITask , JY5211.JY5211COTask , JY5211.JY5211DITask , JY5211.JY5211DOTask

- w -

  • WaitUntilDone() : JY5211.JY5211CITask , JY5211.JY5211COTask
  • WriteData() : JY5211.JY5211COTask
  • WriteSinglePoint() : JY5211.JY5211COTask , JY5211.JY5211DOTask


5211 C# Programming Manual: Class Members - Properties

- a -

  • AvailableSamples : JY5211.JY5211CITask
  • AvaliableLenInSamples : JY5211.JY5211COTask

- c -

  • ChannelID : JY5211.JY5211CITask , JY5211.JY5211COTask

- d -

  • Device : JY5211.JY5211CITask , JY5211.JY5211COTask , JY5211.JY5211DITask , JY5211.JY5211DOTask
  • Digital : JY5211.COTrigger

- e -

  • Edge : JY5211.CODigitalTrigger
  • EdgeCounting : JY5211.JY5211CITask
  • External : JY5211.COTimebase

- f -

  • Frequency : JY5211.COExternalTimebase
  • FrequencyMeas : JY5211.JY5211CITask

- i -

  • IdleState : JY5211.JY5211COTask
  • InitialDelay : JY5211.JY5211COTask
  • IsRuning : JY5211.JY5211CITask , JY5211.JY5211COTask , JY5211.JY5211DITask , JY5211.JY5211DOTask

- l -

  • Lines : JY5211.JY5211DITask , JY5211.JY5211DOTask

- m -

  • Mode : JY5211.JY5211CITask , JY5211.JY5211COTask

- o -

  • OutputTerminal : JY5211.JY5211COTask

- p -

  • PeriodMeas : JY5211.JY5211CITask
  • PulseMeas : JY5211.JY5211CITask

- q -

  • QuadEncoder : JY5211.JY5211CITask

- s -

  • SampleClock : JY5211.JY5211CITask
  • SamplesToAcquire : JY5211.JY5211CITask
  • SignalExport : JY5211.JY5211CITask , JY5211.JY5211COTask
  • Source : JY5211.CODigitalTrigger , JY5211.COTimebase
  • Sync : JY5211.JY5211CITask , JY5211.JY5211COTask

- t -

  • Terminal : JY5211.COExternalTimebase
  • Timebase : JY5211.JY5211COTask
  • TransferedPulses : JY5211.JY5211COTask
  • TransferedSamples : JY5211.JY5211CITask , JY5211.JY5211COTask
  • Trigger : JY5211.JY5211CITask , JY5211.JY5211COTask
  • TwoEdgeSeparation : JY5211.JY5211CITask
  • TwoPulseEncoder : JY5211.JY5211CITask
  • Type : JY5211.COTrigger , JY5211.JY5211CITask


5211 C# Programming Manual: Main Page

5211 C# Programming Manual Documentation


5211 C# Programming Manual: JY5211 Namespace Reference

Classes | Enumerations
JY5211 Namespace Reference

Classes

class | JY5211CITask
class | CISignalExport
CI Signal Export Class More...
class | JY5211COTask
class | COTrigger
class | CODigitalTrigger
class | COExternalTimebase
class | COTimebase
class | COSignalExport
CI Signal Export Class More...
class | JY5211DITask
class | JY5211DOTask

Enumerations

enum class | CIMode { Single = JY5211Import.JY5211_CI_Single , Finite = JY5211Import.JY5211_CI_Finite , Continuous = JY5211Import.JY5211_CI_Continuous }
enum class CIType {
EdgeCounting , Frequency , Period , Pulse ,
TwoEdgeSeparation , QuadEncoder , TwoPulseEncoder
}
enum class | CISignalExportSource { StartTrig , SampleClock }
SourceSignal More...
enum class | COIdleState { HighLevel = JY5211Import.JY5211_CO_HighLevel , LowLevel = JY5211Import.JY5211_CO_LowLevel }
enum class | COMode { Single = JY5211Import.JY5211_CO_Single , Finite = JY5211Import.JY5211_CO_Finite , ContinuousWrapping = JY5211Import.JY5211_CO_ContinuousWrapping , ContinuousNoWrapping = JY5211Import.JY5211_CO_ContinuousNoWrapping }
enum class | COTriggerType { Immediate = JY5211Import.JY5211_TriggerType_Immediately , Digital = JY5211Import.JY5211_TriggerType_Digital , Software = JY5211Import.JY5211_TriggerType_Soft }
enum class | CODigitalTriggerEdge { Rising }
enum class | COTimebaseSource { Internal200MHz = JY5211Import.JY5211_Internal_MainClk_200M , Internal5MHz = JY5211Import.JY5211_Internal_Timebase_5M , Internal100kHz = JY5211Import.JY5211_Internal_Timebase_100K , External = JY5211Import.JY5211_External_Timebase }
enum class | COSignalExportSource { StartTrig }
SourceSignal More...

Enumeration Type Documentation

◆ CIMode

enum JY5211.CIMode
strong

计数器输入采样模式

Counter Input Sample Mode

Enumerator
Single | 单点模式 Single
Finite | 有限点模式 Finite
Continuous | 连续模式 Continuous

◆ CISignalExportSource

enum JY5211.CISignalExportSource
strong

SourceSignal

Enumerator
StartTrig | CI_StartTrig
SampleClock | CI_SampleClock

◆ CIType

enum JY5211.CIType
strong

计数器输入应用类型

Counter Input Application Type

Enumerator
EdgeCounting | 边沿计数 Edge Counting
Frequency | 频率测量 Freqquency Measurement
Period | 周期测量 Period Measurement
Pulse | 脉冲测量 Pulse Measurement
TwoEdgeSeparation | 双边沿间隔 Two-Edge Separation Measurement
QuadEncoder | 正交编码 Quadrature Encoder
TwoPulseEncoder | 双脉冲编码 Two-Pulse Encoder

◆ CODigitalTriggerEdge

enum JY5211.CODigitalTriggerEdge
strong

数字触发边沿

Digital Trigger Edge

Enumerator
Rising

上升沿

RisingEdge

◆ COIdleState

enum JY5211.COIdleState
strong

输出开始前和停止后的空闲状态

Idle state when pulse output before start and after stop.

Enumerator
HighLevel | 空闲状态为高电平 Idle state is high level.
LowLevel | 空闲状态为低电平 Idle state is low level.

◆ COMode

enum JY5211.COMode
strong

输出模式

Counter Output Mode

Enumerator
Single | 单配置脉冲输出 Single configration pulse output
Finite | 有限重配置脉冲输出 Finite reconfiguration pulse output
ContinuousWrapping | 连续重配置脉冲输出（环绕模式） Continuous reconfiguration pulse output with warpping
ContinuousNoWrapping | 连续重配置脉冲输出（非环绕） Continuous reconfiguration pulse output without warpping

◆ COSignalExportSource

enum JY5211.COSignalExportSource
strong

SourceSignal

Enumerator
StartTrig

CO_StartTrig

◆ COTimebaseSource

enum JY5211.COTimebaseSource
strong

时基源

Timebase source

Enumerator
Internal200MHz | 内部200MHz时基 Internal 200MHz Timebase
Internal5MHz | 内部5MHz时基 Internal 5MHz Timebase
Internal100kHz | 内部100kHz时基 Internal 100kHz Timebase
External | 外部时基 External Timebase

◆ COTriggerType

enum JY5211.COTriggerType
strong

开始触发类型

Trigger Type

Enumerator
Immediate | 立即触发 Immediate Trigger
Digital | 数字触发 Digital Trigger
Software | 软件触发 Software Trigger


5211 C# Programming Manual: Package Functions

Here is a list of all namespace members with links to the namespace documentation for each member:
  • CIMode : JY5211
  • CISignalExportSource : JY5211
  • CIType : JY5211
  • CODigitalTriggerEdge : JY5211
  • COIdleState : JY5211
  • COMode : JY5211
  • COSignalExportSource : JY5211
  • COTimebaseSource : JY5211
  • COTriggerType : JY5211


5211 C# Programming Manual: Package Functions

  • CIMode : JY5211
  • CISignalExportSource : JY5211
  • CIType : JY5211
  • CODigitalTriggerEdge : JY5211
  • COIdleState : JY5211
  • COMode : JY5211
  • COSignalExportSource : JY5211
  • COTimebaseSource : JY5211
  • COTriggerType : JY5211


5211 C# Programming Manual: Packages

Packages
Here are the packages with brief descriptions (if available):
[detail level 12]
▼N JY5211 |
C JY5211CITask |
C CISignalExport | CI Signal Export Class
C JY5211COTask |
C COTrigger |
C CODigitalTrigger |
C COExternalTimebase |
C COTimebase |
C COSignalExport | CI Signal Export Class
C JY5211DITask |
C JY5211DOTask |